La Xerox Phaser 3116 en Debian Etch


Uno de las pocas cosas que en mi caso no salen funcionando de una después de la instalación de Debian Etch es la impresora. Esto no es culpa de los muchachos de Debian, sino que tengo una Phaser 3116 de la gente de Xerox, y que no hay un soporte oficial del Xerox para esta impresora en Linux.

Pero en este caso no es problema, ya que las impresoras Xerox Phaser 3116 y la Samsung ML-1520 no solo comparten su aspecto fisico, como pueden ver en las fotos, sino que también compraten su electrónica y por ende sus controladores.

Para manejar las impresiones en Linux no hay como CUPS (Common Unix Printer System), pero en este caso CUPS no soporta directamente ninguna de estas dos impresoras, por lo que debemos instalar el paquete foomatic-filters-ppds el cual trae es una coleccion de drivers para impresoras soportadas por linuxprinter.org (http://www.linux-foundation.org/en/OpenPrinting).

Foomatic es un sistema diseñado para Debian y después exportados a otras distribuciones para manejar de manera simple el soporte de las impresoras generado por linuxprinter.org proveyendo una "unión" entre las colas de impresión (como CUPS o lpr) y las impresoras.

PPD son las siglas de Postscript Printer Description, y los archivos ppd no son mas que archivos que describen como trabajan las impresoras postscript y se utilizaron originalmente para dar soporte y definir todas las facilidades de este tipo de impresoras en los sistemas Linux y Unix. Hoy en día a través de los archivos PPD se pueda dar soporte a la mayorías de las impresoras del mercado, sean o no Postscript. El paquete foomatic-filters-ppds es una colección de archivos ppd, que en conjunto con el paquete hpijs-ppds, describen a todas las impresoras que NO SON POSTSCRIPT que están soportadas por linuxprinting.org.

La receta

Aca viene la receta de cocina para configurar la impresora Xerox Phaser 3116 en Debian Etch 4.0 (estable). Que necesitamos
  • Una impresora Xerox Phaser 3116 con su cable USB ( Ovvvvbio ).
  • Servidor CUPS instalado y funcionando.
  • Un navegador Web.
  • Los repositorios oficiales de Debian definidos en el /etc/apt/source.list y actualizados.

El primer paso es instalar el sistema Foomatic y los archivos PPD:
aptitude install foomatic-db foomatic-db-engine foomatic-db-hpijs foomatic-filters-ppds
Una ves instalado los archivos PPD, abrimos nuestro navegador Web y entramos al servidor CUPS ( http://127.0.0.1:631 ). Desde la sección "Administración" agregamos las nuevas impresoras. Si todo esta bien configurado y ENCENDIDO (me refiero a la impresora, ovbio) encontraremos en "Impresoras" una opción para agregar nuestra impresora "XEROX PAHSER 3116". Seleccionamos "Añadir esta impresora". Cabe destacar que para realizar cualquier tarea de administración, CUPS nos solicitara la clave de root.

En la siguiente interfase nos pedira seleccionar nuestro controlador o que le especifiquemos el archivo PPD. Nosotros optaremos por esta segunda opción. Todos los archivos PPD instalados por el paquete foomatic-filters-ppd se encuentran en el directorio /usr/share/ppd/foomatic-rip/ y en nuestro caso el archivo en particular se encuentra en:
/usr/share/ppd/foomatic-rip/linuxprinting.org-gs-builtin/Samsung/Samsung-ML-1520-gdi.ppd.gz
Buscamos y seleccionamos el archivo ppd de la impresora Samsung ML 1520 y presionamos el boton de "Añadir Impresora". En la siguiente interfase podremos definir las propiedades de nuestras impresora, siendo una de las casi obligadas a cambiar la del tamaño del papel de "letter" a "A4".

Una ves instalada y configurada nuestras impresora ya podremos usarla sin problemas desde cualquier aplicacion de nuestro Debian.

2 comentarios:

$üÞë® Må®ç¥ånø

9 de abril de 2008, 13:43

En Ubuntu es más fácil instalar la Xerox 3116.

Yo tengo una de esas.

Yaneth Carvajal. Tutora Informática Educativa

28 de octubre de 2013, 14:12

Muchas gracias! Me sirvió el post para instalar mi Phaser 3117 en la versión de Canaima 3.0 de Linux. Sólo tuve que instalar los paquetes de foomatic y automáticamente aparecieron los controladores necesarios al configurar la impresora en el modo gráfico, donde también automáticamente el programa sugirió el contorolador para Phaser 3110, con el cual funcinó perfectamente. Muchas gracias de nuevo!